using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""row container-items"">(.+?)\n\n<\/div>";
string input = @"<div class=""row container-items"">
<div class=""col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block"">
<div class=""panel panel-default"">
<div class=""panel-body image-panel"">
<a href=""/p/{% p_link %}"">
<div class=""item_image"">
<img src=""/data/sorted/{% image_src %}"">
</div>
</a>
</div>
<div class=""panel-footer"">
<div class=""panel-heading category_view"">
<div class=""text-left"">
<font color=""#777"">{% item_category %}</font>
</div>
<div class=""text-right"">{% count_view %}</div>
</div>
<!--<div class=""caption_view"">
{% item_caption %}
</div> -->
<a href=""/p/{% p_link %}"">посмотреть...</a>
</div>
</div>
</div>
<div class=""col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block"">
<div class=""panel panel-default"">
<div class=""panel-body image-panel"">
<a href=""/p/{% p_link %}"">
<div class=""item_image"">
<img src=""/data/sorted/{% image_src %}"">
</div>
</a>
</div>
<div class=""panel-footer"">
<div class=""panel-heading category_view"">
<div class=""text-left"">
<font color=""#777"">{% item_category %}</font>
</div>
<div class=""text-right"">{% count_view %}</div>
</div>
<!--<div class=""caption_view"">
{% item_caption %}
</div> -->
<a href=""/p/{% p_link %}"">посмотреть...</a>
</div>
</div>
</div>
</div>";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}