import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"<div class="row container-items">(.+?)\n\n<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
<div class="row container-items">
<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">
<div class="panel panel-default">
<div class="panel-body image-panel">
<a href="/p/{% p_link %}">
<div class="item_image">
<img src="/data/sorted/{% image_src %}">
</div>
</a>
</div>
<div class="panel-footer">
<div class="panel-heading category_view">
<div class="text-left">
<font color="#777">{% item_category %}</font>
</div>
<div class="text-right">{% count_view %}</div>
</div>
<!--<div class="caption_view">
{% item_caption %}
</div> -->
<a href="/p/{% p_link %}">посмотреть...</a>
</div>
</div>
</div>
<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">
<div class="panel panel-default">
<div class="panel-body image-panel">
<a href="/p/{% p_link %}">
<div class="item_image">
<img src="/data/sorted/{% image_src %}">
</div>
</a>
</div>
<div class="panel-footer">
<div class="panel-heading category_view">
<div class="text-left">
<font color="#777">{% item_category %}</font>
</div>
<div class="text-right">{% count_view %}</div>
</div>
<!--<div class="caption_view">
{% item_caption %}
</div> -->
<a href="/p/{% p_link %}">посмотреть...</a>
</div>
</div>
</div>
</div>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}