use strict;
my $str = '<div class="row container-items">
<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">
<div class="panel panel-default">
<div class="panel-body image-panel">
<a href="/p/{% p_link %}">
<div class="item_image">
<img src="/data/sorted/{% image_src %}">
</div>
</a>
</div>
<div class="panel-footer">
<div class="panel-heading category_view">
<div class="text-left">
<font color="#777">{% item_category %}</font>
</div>
<div class="text-right">{% count_view %}</div>
</div>
<!--<div class="caption_view">
{% item_caption %}
</div> -->
<a href="/p/{% p_link %}">посмотреть...</a>
</div>
</div>
</div>
<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">
<div class="panel panel-default">
<div class="panel-body image-panel">
<a href="/p/{% p_link %}">
<div class="item_image">
<img src="/data/sorted/{% image_src %}">
</div>
</a>
</div>
<div class="panel-footer">
<div class="panel-heading category_view">
<div class="text-left">
<font color="#777">{% item_category %}</font>
</div>
<div class="text-right">{% count_view %}</div>
</div>
<!--<div class="caption_view">
{% item_caption %}
</div> -->
<a href="/p/{% p_link %}">посмотреть...</a>
</div>
</div>
</div>
</div>';
my $regex = qr/<div class="row container-items">(.+?)\n\n<\/div>/usp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}