// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?us)<div class="row container-items">(.+?)\n\n<\/div>"#).unwrap();
let string = "<div class=\"row container-items\">
<div class=\"col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block\">
<div class=\"panel panel-default\">
<div class=\"panel-body image-panel\">
<a href=\"/p/{% p_link %}\">
<div class=\"item_image\">
<img src=\"/data/sorted/{% image_src %}\">
</div>
</a>
</div>
<div class=\"panel-footer\">
<div class=\"panel-heading category_view\">
<div class=\"text-left\">
<font color=\"#777\">{% item_category %}</font>
</div>
<div class=\"text-right\">{% count_view %}</div>
</div>
<!--<div class=\"caption_view\">
{% item_caption %}
</div> -->
<a href=\"/p/{% p_link %}\">посмотреть...</a>
</div>
</div>
</div>
<div class=\"col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block\">
<div class=\"panel panel-default\">
<div class=\"panel-body image-panel\">
<a href=\"/p/{% p_link %}\">
<div class=\"item_image\">
<img src=\"/data/sorted/{% image_src %}\">
</div>
</a>
</div>
<div class=\"panel-footer\">
<div class=\"panel-heading category_view\">
<div class=\"text-left\">
<font color=\"#777\">{% item_category %}</font>
</div>
<div class=\"text-right\">{% count_view %}</div>
</div>
<!--<div class=\"caption_view\">
{% item_caption %}
</div> -->
<a href=\"/p/{% p_link %}\">посмотреть...</a>
</div>
</div>
</div>
</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}