import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"row container-items\">(.+?)\\n\\n<\\/div>";
final String string = "<div class=\"row container-items\">\n\n"
+ "<div class=\"col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block\">\n"
+ " <div class=\"panel panel-default\">\n"
+ " <div class=\"panel-body image-panel\">\n"
+ " <a href=\"/p/{% p_link %}\">\n"
+ " <div class=\"item_image\">\n"
+ " <img src=\"/data/sorted/{% image_src %}\">\n"
+ " </div>\n"
+ " </a>\n"
+ " </div>\n"
+ " <div class=\"panel-footer\">\n"
+ " <div class=\"panel-heading category_view\">\n"
+ " <div class=\"text-left\">\n"
+ " <font color=\"#777\">{% item_category %}</font>\n"
+ " </div>\n"
+ " <div class=\"text-right\">{% count_view %}</div>\n"
+ " </div>\n"
+ " <!--<div class=\"caption_view\">\n"
+ " {% item_caption %}\n"
+ " </div> -->\n"
+ " <a href=\"/p/{% p_link %}\">посмотреть...</a>\n"
+ " </div>\n"
+ " </div>\n"
+ "</div>\n"
+ "<div class=\"col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block\">\n"
+ " <div class=\"panel panel-default\">\n"
+ " <div class=\"panel-body image-panel\">\n"
+ " <a href=\"/p/{% p_link %}\">\n"
+ " <div class=\"item_image\">\n"
+ " <img src=\"/data/sorted/{% image_src %}\">\n"
+ " </div>\n"
+ " </a>\n"
+ " </div>\n"
+ " <div class=\"panel-footer\">\n"
+ " <div class=\"panel-heading category_view\">\n"
+ " <div class=\"text-left\">\n"
+ " <font color=\"#777\">{% item_category %}</font>\n"
+ " </div>\n"
+ " <div class=\"text-right\">{% count_view %}</div>\n"
+ " </div>\n"
+ " <!--<div class=\"caption_view\">\n"
+ " {% item_caption %}\n"
+ " </div> -->\n"
+ " <a href=\"/p/{% p_link %}\">посмотреть...</a>\n"
+ " </div>\n"
+ " </div>\n"
+ "</div>\n\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}