#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\?r=([0-9]+)"
Local $sString = "<head>" & @CRLF & _
" ..." & @CRLF & _
" <link type="text/css" href="app.css?r=1" rel="stylesheet">" & @CRLF & _
" ..." & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
" ..." & @CRLF & _
" <script type="text/javascript" src="app.js?r=1"></script>" & @CRLF & _
"</body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")