re = /\?r=([0-9]+)/
str = '<head>
...
<link type="text/css" href="app.css?r=1" rel="stylesheet">
...
</head>
<body>
...
<script type="text/javascript" src="app.js?r=1"></script>
</body>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end