import Foundation
let pattern = #"\?r=([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<head>
...
<link type="text/css" href="app.css?r=1" rel="stylesheet">
...
</head>
<body>
...
<script type="text/javascript" src="app.js?r=1"></script>
</body>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)