using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?r=([0-9]+)";
string input = @"<head>
...
<link type=""text/css"" href=""app.css?r=1"" rel=""stylesheet"">
...
</head>
<body>
...
<script type=""text/javascript"" src=""app.js?r=1""></script>
</body>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}