package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\?r=([0-9]+)`)
var str = `<head>
...
<link type="text/css" href="app.css?r=1" rel="stylesheet">
...
</head>
<body>
...
<script type="text/javascript" src="app.js?r=1"></script>
</body>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}