const regex = /\?r=([0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\?r=([0-9]+)', 'g')
const str = `<head>
...
<link type="text/css" href="app.css?r=1" rel="stylesheet">
...
</head>
<body>
...
<script type="text/javascript" src="app.js?r=1"></script>
</body>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}