# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/http:\\/\\/.+\\/b2citmdsp\.pgm[^=]+=(.*)/http:\/\/www.newdomain.com\/prodpage.pgm?item=\1/;t' <<< "http://www.olddomain.com/b2c/b2citmdsp.pgm?pp_skmno=18297
http://www.olddomain.com/b2c/blablabla.pgm?pp_skmno=18297"