import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/.+\\/b2citmdsp\\.pgm[^=]+=(.*)";
final String string = "http://www.olddomain.com/b2c/b2citmdsp.pgm?pp_skmno=18297\n"
+ "http://www.olddomain.com/b2c/blablabla.pgm?pp_skmno=18297";
final String subst = "http://www.newdomain.com/prodpage.pgm?item=\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}