$re = '/http:\/\/.+\/b2citmdsp\.pgm[^=]+=(.*)/';
$str = 'http://www.olddomain.com/b2c/b2citmdsp.pgm?pp_skmno=18297
http://www.olddomain.com/b2c/blablabla.pgm?pp_skmno=18297';
$subst = "http://www.newdomain.com/prodpage.pgm?item=\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;