const regex = /http:\/\/.+\/b2citmdsp\.pgm[^=]+=(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/.+\\\/b2citmdsp\\.pgm[^=]+=(.*)', '')
const str = `http://www.olddomain.com/b2c/b2citmdsp.pgm?pp_skmno=18297
http://www.olddomain.com/b2c/blablabla.pgm?pp_skmno=18297`;
const subst = `http://www.newdomain.com/prodpage.pgm?item=\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);