// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http:\/\/.+\/b2citmdsp\.pgm[^=]+=(.*)").unwrap();
let string = "http://www.olddomain.com/b2c/b2citmdsp.pgm?pp_skmno=18297
http://www.olddomain.com/b2c/blablabla.pgm?pp_skmno=18297";
let substitution = "http://www.newdomain.com/prodpage.pgm?item=\\1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}