#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<foo>(.*?)<\/foo>"
Local $sString = "<foo><some special chars>!@#$%^&*</foo> sure, why not" & @CRLF & _
"" & @CRLF & _
"<foo>Lorem</foo>" & @CRLF & _
"" & @CRLF & _
"<foo>ipsum</foo>" & @CRLF & _
"" & @CRLF & _
"<foo>sit</foo>" & @CRLF & _
"" & @CRLF & _
"<foo>dolor</foo>" & @CRLF & _
"" & @CRLF & _
"<foo>amet</foo>" & @CRLF & _
"" & @CRLF & _
"<bar>elm stuff</bar>" & @CRLF & _
"" & @CRLF & _
"more stuff for you <foo> something </foo> and even more stuff <foo>yes</foo>" & @CRLF & _
"" & @CRLF & _
"Let's deal with nesting: <foo> some text <foo> a child foo!</foo> let's close the parent</foo>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")