re = /<foo>(.*?)<\/foo>/m
str = '<foo><some special chars>!@#$%^&*</foo> sure, why not
<foo>Lorem</foo>
<foo>ipsum</foo>
<foo>sit</foo>
<foo>dolor</foo>
<foo>amet</foo>
<bar>elm stuff</bar>
more stuff for you <foo> something </foo> and even more stuff <foo>yes</foo>
Let\'s deal with nesting: <foo> some text <foo> a child foo!</foo> let\'s close the parent</foo>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end