import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<foo>(.*?)<\\/foo>";
final String string = "<foo><some special chars>!@#$%^&*</foo> sure, why not\n\n"
+ "<foo>Lorem</foo>\n\n"
+ "<foo>ipsum</foo>\n\n"
+ "<foo>sit</foo>\n\n"
+ "<foo>dolor</foo>\n\n"
+ "<foo>amet</foo>\n\n"
+ "<bar>elm stuff</bar>\n\n"
+ "more stuff for you <foo> something </foo> and even more stuff <foo>yes</foo>\n\n"
+ "Let's deal with nesting: <foo> some text <foo> a child foo!</foo> let's close the parent</foo>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}