using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<foo>(.*?)<\/foo>";
string input = @"<foo><some special chars>!@#$%^&*</foo> sure, why not
<foo>Lorem</foo>
<foo>ipsum</foo>
<foo>sit</foo>
<foo>dolor</foo>
<foo>amet</foo>
<bar>elm stuff</bar>
more stuff for you <foo> something </foo> and even more stuff <foo>yes</foo>
Let's deal with nesting: <foo> some text <foo> a child foo!</foo> let's close the parent</foo>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}