package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<foo>(.*?)<\/foo>`)
var str = `<foo><some special chars>!@#$%^&*</foo> sure, why not
<foo>Lorem</foo>
<foo>ipsum</foo>
<foo>sit</foo>
<foo>dolor</foo>
<foo>amet</foo>
<bar>elm stuff</bar>
more stuff for you <foo> something </foo> and even more stuff <foo>yes</foo>
Let's deal with nesting: <foo> some text <foo> a child foo!</foo> let's close the parent</foo>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}