const regex = /<foo>(.*?)<\/foo>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<foo>(.*?)<\\\/foo>', 'gm')
const str = `<foo><some special chars>!@#\$%^&*</foo> sure, why not
<foo>Lorem</foo>
<foo>ipsum</foo>
<foo>sit</foo>
<foo>dolor</foo>
<foo>amet</foo>
<bar>elm stuff</bar>
more stuff for you <foo> something </foo> and even more stuff <foo>yes</foo>
Let's deal with nesting: <foo> some text <foo> a child foo!</foo> let's close the parent</foo>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}