#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*?я).*"
Local $sString = "Все это время мы либо маемся от безделья, либо отчаянно бьемся" & @CRLF & _
"мы либо маемся от безделья, либо отчаянно бьемся" & @CRLF & _
"от безделья, либо отчаянно бьемся" & @CRLF & _
"либо отчаянно бьемся"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")