re = /(.*?я).*/
str = 'Все это время мы либо маемся от безделья, либо отчаянно бьемся
мы либо маемся от безделья, либо отчаянно бьемся
от безделья, либо отчаянно бьемся
либо отчаянно бьемся'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end