// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*?я).*").unwrap();
let string = "Все это время мы либо маемся от безделья, либо отчаянно бьемся
мы либо маемся от безделья, либо отчаянно бьемся
от безделья, либо отчаянно бьемся
либо отчаянно бьемся";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}