$re = '/(.*?я).*/';
$str = 'Все это время мы либо маемся от безделья, либо отчаянно бьемся
мы либо маемся от безделья, либо отчаянно бьемся
от безделья, либо отчаянно бьемся
либо отчаянно бьемся';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);