using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?я).*";
string input = @"Все это время мы либо маемся от безделья, либо отчая нно бьемся
мы либо маемся от безделья, либо отчаянно бьемся
от безделья, либо отчаянно бьемся
либо отчаянно бьемся";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}