package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?я).*`)
var str = `Все это время мы либо маемся от безделья, либо отчаянно бьемся
мы либо маемся от безделья, либо отчаянно бьемся
от безделья, либо отчаянно бьемся
либо отчаянно бьемся`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}