# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\](\d{1,2}\\/\d{2}\\/\d{4})\s([^\[]+)\[/<$1$2>/g;t' <<< "[vc_row][vc_column width=\"1/1\"]28/04/2015 Text description[vc_row][vc_column width=\"1/1\"][vc_row][vc_column width=\"1/1\"]29/04/2015 Text description 2[vc_row][vc_column width=\"1/1\"]"