// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\](\d{1,2}\/\d{2}\/\d{4})\s([^\[]+)\[").unwrap();
let string = "[vc_row][vc_column width=\"1/1\"]28/04/2015 Text description[vc_row][vc_column width=\"1/1\"][vc_row][vc_column width=\"1/1\"]29/04/2015 Text description 2[vc_row][vc_column width=\"1/1\"]";
let substitution = "<$1$2>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}