using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\](\d{1,2}\/\d{2}\/\d{4})\s([^\[]+)\[";
string substitution = @"<$1$2>";
string input = @"[vc_row][vc_column width=""1/1""]28/04/2015 Text description[vc_row][vc_column width=""1/1""][vc_row][vc_column width=""1/1""]29/04/2015 Text description 2[vc_row][vc_column width=""1/1""]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}