package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\](\d{1,2}\/\d{2}\/\d{4})\s([^\[]+)\[`)
var str = `[vc_row][vc_column width="1/1"]28/04/2015 Text description[vc_row][vc_column width="1/1"][vc_row][vc_column width="1/1"]29/04/2015 Text description 2[vc_row][vc_column width="1/1"]`
var substitution = "<$1$2>"
fmt.Println(re.ReplaceAllString(str, substitution))
}