import Foundation
let pattern = #"\](\d{1,2}\/\d{2}\/\d{4})\s([^\[]+)\["#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[vc_row][vc_column width="1/1"]28/04/2015 Text description[vc_row][vc_column width="1/1"][vc_row][vc_column width="1/1"]29/04/2015 Text description 2[vc_row][vc_column width="1/1"]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1$2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)