use strict;
my $str = '[vc_row][vc_column width="1/1"]28/04/2015 Text description[vc_row][vc_column width="1/1"][vc_row][vc_column width="1/1"]29/04/2015 Text description 2[vc_row][vc_column width="1/1"]';
my $regex = qr/\](\d{1,2}\/\d{2}\/\d{4})\s([^\[]+)\[/p;
my $subst = '<$1$2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";