#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([5-9]|\d\d|[1-4]\d\d|5[0-4]\d|55[0-5])$"
Local $sString = "1" & @CRLF & _
"5" & @CRLF & _
"10" & @CRLF & _
"37" & @CRLF & _
"50" & @CRLF & _
"59" & @CRLF & _
"78" & @CRLF & _
"100" & @CRLF & _
"156" & @CRLF & _
"200" & @CRLF & _
"235" & @CRLF & _
"400" & @CRLF & _
"409" & @CRLF & _
"500" & @CRLF & _
"534" & @CRLF & _
"550" & @CRLF & _
"553" & @CRLF & _
"555" & @CRLF & _
"557" & @CRLF & _
"599" & @CRLF & _
"600"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")