use strict;
my $str = '1
5
10
37
50
59
78
100
156
200
235
400
409
500
534
550
553
555
557
599
600';
my $regex = qr/^([5-9]|\d\d|[1-4]\d\d|5[0-4]\d|55[0-5])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}