using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([5-9]|\d\d|[1-4]\d\d|5[0-4]\d|55[0-5])$";
string input = @"1
5
10
37
50
59
78
100
156
200
235
400
409
500
534
550
553
555
557
599
600";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}