$re = '/^([5-9]|\d\d|[1-4]\d\d|5[0-4]\d|55[0-5])$/m';
$str = '1
5
10
37
50
59
78
100
156
200
235
400
409
500
534
550
553
555
557
599
600';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);