# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([5-9]|\d\d|[1-4]\d\d|5[0-4]\d|55[0-5])$"
test_str = ("1\n"
"5\n"
"10\n"
"37\n"
"50\n"
"59\n"
"78\n"
"100\n"
"156\n"
"200\n"
"235\n"
"400\n"
"409\n"
"500\n"
"534\n"
"550\n"
"553\n"
"555\n"
"557\n"
"599\n"
"600")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.