// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([5-9]|\d\d|[1-4]\d\d|5[0-4]\d|55[0-5])$").unwrap();
let string = "1
5
10
37
50
59
78
100
156
200
235
400
409
500
534
550
553
555
557
599
600";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}