#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s+#\w+"
Local $sString = "asdf apsodf pas dfpa spdf aspd #hash"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)