use strict;
my $str = 'asdf apsodf pas dfpa spdf aspd #hash';
my $regex = qr/\s+#\w+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";