import re
regex = re.compile(r"\s+#\w+")
test_str = "asdf apsodf pas dfpa spdf aspd #hash"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)