const regex = /\s+#\w+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+#\\w+', '')
const str = `asdf apsodf pas dfpa spdf aspd #hash`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);