using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+#\w+";
string substitution = @"";
string input = @"asdf apsodf pas dfpa spdf aspd #hash";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}