$re = '/\s+#\w+/';
$str = 'asdf apsodf pas dfpa spdf aspd #hash';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;