# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?modulos\\/\w*\\/)(.*\\/).*/\1/;t' <<< "flex_src/br/com/mresolucoes/atta/modulos/vendasProduto/modulos/relatorios/valoresAutoJasper/AbaRelatorioValoresScript.as"