using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?modulos\/\w*\/)(.*\/).*";
string substitution = @"\1";
string input = @"flex_src/br/com/mresolucoes/atta/modulos/vendasProduto/modulos/relatorios/valoresAutoJasper/AbaRelatorioValoresScript.as";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}