use strict;
my $str = 'flex_src/br/com/mresolucoes/atta/modulos/vendasProduto/modulos/relatorios/valoresAutoJasper/AbaRelatorioValoresScript.as';
my $regex = qr/(.*?modulos\/\w*\/)(.*\/).*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";