re = /(.*?modulos\/\w*\/)(.*\/).*/
str = 'flex_src/br/com/mresolucoes/atta/modulos/vendasProduto/modulos/relatorios/valoresAutoJasper/AbaRelatorioValoresScript.as'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result